Home | News | Projects | Releases
Bugs | RFE | Repositories | Help
Fix broken Linux and Windows builds
[xestiaab/.git] / source / tools / CMakeLists.txt
index 8f1e901..fb9e8b8 100644 (file)
@@ -2,16 +2,22 @@ add_executable(bitmapcode
     bitmapcode.cpp)
 
 if (MSVC)
-add_custom_command(
-    TARGET bitmapcode
-    POST_BUILD
-    COMMAND $(OutDir)/bitmapcode ${CMAKE_SOURCE_DIR}/bitmaps)
+    add_custom_command(
+        TARGET bitmapcode
+        POST_BUILD
+        COMMAND $(OutDir)/bitmapcode ${CMAKE_SOURCE_DIR}/bitmaps)
+endif()
+
+if (APPLE)
+    target_link_libraries(bitmapcode
+        LINK_PUBLIC
+        c++
+        ${wxWidgets_LIBRARIES})
+else()
+    target_link_libraries(bitmapcode
+        LINK_PUBLIC
+        ${wxWidgets_LIBRARIES})
 endif()
-    
-target_link_libraries(bitmapcode
-    LINK_PUBLIC
-    c++
-    ${wxWidgets_LIBRARIES})
 
 set (sources 
     odthelpbrowser/base64.cpp
Xestia Software Development
Yn Maystri
© 2006 - 2019 Xestia Software Development
Software

Xestia Address Book
Xestia Calendar
Development

Xestia Gelforn
Everything else

About
News
Privacy Policy