Home | News | Projects | Releases
Bugs | RFE | Repositories | Help
Setup CMake to build for macOS
[xestiaab/.git] / source / tools / CMakeLists.txt
index a34ec67..8f1e901 100644 (file)
@@ -1,6 +1,6 @@
 add_executable(bitmapcode
     bitmapcode.cpp)
-    
+
 if (MSVC)
 add_custom_command(
     TARGET bitmapcode
@@ -10,6 +10,7 @@ endif()
     
 target_link_libraries(bitmapcode
     LINK_PUBLIC
+    c++
     ${wxWidgets_LIBRARIES})
 
 set (sources 
@@ -26,6 +27,8 @@ set (sources
 
 if (WIN32)
     add_executable(odthelpbrowser WIN32 ${sources})
+elseif (APPLE)
+    add_executable(odthelpbrowser MACOSX_BUNDLE ${sources})
 else()
     add_executable(odthelpbrowser ${sources})
 endif()
Xestia Software Development
Yn Maystri
© 2006 - 2019 Xestia Software Development
Software

Xestia Address Book
Xestia Calendar
Development

Xestia Gelforn
Everything else

About
News
Privacy Policy