Home | News | Projects | Releases
Bugs | RFE | Repositories | Help
Updated build system to properly include checking of libxml2 via xml2-config --cflags
[xestiaab/.git] / source / configure.ac
index 9a51688..c2582f6 100644 (file)
@@ -109,6 +109,18 @@ variable before running configure again."
 
 # libxml2 Library
 
+CPPFLAGSOLD=CPPFLAGS
+CPPFLAGS=`xml2-config --cflags`
+
+AC_CHECK_PROG([FOUND_XML2CONFIG], [xml2-config], [yes], [no]) 
+AM_CONDITIONAL([FOUND_XML2CONFIG_RES], [test x$FOUND_XML2CONFIG = xyes])
+
+AM_COND_IF([FOUND_XML2CONFIG_RES], [], [echo "Cannot find the xml2-config program on your system.
+If it is installed on your system, adjust your PATH environment
+variable before running configure again."
+       exit -1
+       ])
+
 AC_CHECK_LIB([xml2], [main], [], [echo "The libxml2 library must be installed on your system.
 Please check that this library is installed properly before
 running configure again."
@@ -121,14 +133,7 @@ before running configure again."
        exit -1
        ])
 
-AC_CHECK_PROG([FOUND_XML2CONFIG], [xml2-config], [yes], [no]) 
-AM_CONDITIONAL([FOUND_XML2CONFIG_RES], [test x$FOUND_XML2CONFIG = xyes])
-
-AM_COND_IF([FOUND_XML2CONFIG_RES], [], [echo "Cannot find the xml2-config program on your system.
-If it is installed on your system, adjust your PATH environment
-variable before running configure again."
-       exit -1
-       ])
+CPPFLAGS=CPPFLAGSOLD
 
 # file application
 
Xestia Software Development
Yn Maystri
© 2006 - 2019 Xestia Software Development
Software

Xestia Address Book
Xestia Calendar
Development

Xestia Gelforn
Everything else

About
News
Privacy Policy