Home | News | Projects | Releases
Bugs | RFE | Repositories | Help
Updated build system
[xestiaab/.git] / source / configure.ac
index cec6ce6..6e792d3 100644 (file)
@@ -93,6 +93,15 @@ before running configure again."
        exit -1
        ])
 
+AC_CHECK_PROG([FOUND_CURLCONFIG], [curl-config], [yes], [no]) 
+AM_CONDITIONAL([FOUND_CURLCONFIG_RES], [test x$FOUND_CURLCONFIG = xyes])
+
+AM_COND_IF([FOUND_CURLCONFIG_RES], [], [echo "Cannot find the curl-config program on your system.
+If it is installed on your system, adjust your PATH environment
+variable before running configure again."
+       exit -1
+       ])
+
 # libxml2 Library
 
 AC_CHECK_LIB([xml2], [main], [], [echo "The libxml2 library must be installed on your system.
@@ -107,6 +116,15 @@ before running configure again."
        exit -1
        ])
 
+AC_CHECK_PROG([FOUND_XML2CONFIG], [xml2-config], [yes], [no]) 
+AM_CONDITIONAL([FOUND_XML2CONFIG_RES], [test x$FOUND_XML2CONFIG = xyes])
+
+AM_COND_IF([FOUND_XML2CONFIG_RES], [], [echo "Cannot find the xml2-config program on your system.
+If it is installed on your system, adjust your PATH environment
+variable before running configure again."
+       exit -1
+       ])
+
 # Checks for header files.
 AC_CHECK_HEADERS([stdlib.h string.h iostream iomanip ios algorithm map vector utility])
 
@@ -127,7 +145,7 @@ AC_ARG_ENABLE([debug],
 # Checks for library functions.
 
 AM_CONDITIONAL([DEBUG], [test x$debug = xtrue])
-AM_COND_IF([DEBUG], [AC_SUBST([DBGOUT], ["-O0"])], [AC_SUBST([DBGOUT], ["-Os"])])
+AM_COND_IF([DEBUG], [AC_SUBST([DBGOUT], ["-O0 -ggdb"])], [AC_SUBST([DBGOUT], ["-Os"])])
 AM_COND_IF([DEBUG], [AC_SUBST([DBGSTATUS], ["DEBUG=true"])], [AC_SUBST([DBGSTATUS], ["DEBUG=false"])])
 AM_COND_IF([DEBUG], [echo "Debugging mode has been enabled."])
 
Xestia Software Development
Yn Maystri
© 2006 - 2019 Xestia Software Development
Software

Xestia Address Book
Xestia Calendar
Development

Xestia Gelforn
Everything else

About
News
Privacy Policy