Home | News | Projects | Releases
Bugs | RFE | Repositories | Help
Move INSTALL, LICENSE, README, THANKS and TODO into root directory
[xestiaab/.git] / source / configure.ac
index ed9cdaf..5834f8b 100644 (file)
@@ -32,6 +32,12 @@ fi
 BINDIR=`eval echo $bindir`
 AC_SUBST([BINDIR])
 
+if test "x$datarootdir" = "xNONE" ; then
+       datarootdir="/share"
+fi
+DATAROOTDIR=`eval echo $datarootdir`
+AC_SUBST([DATAROOTDIR])
+
 # Checks for libraries.
 
 # wxWidgets
@@ -73,6 +79,8 @@ LIBS="$LIBS $WX_LIBS"
 
 # SFML Audio Library
 
+PKG_CHECK_MODULES([SFML], [sfml-all >= 2.4.1])
+
 AC_CHECK_LIB([sfml-audio], [main], [], [echo "The SFML libraries must be installed on your system.
 Please check that this library is installed properly before
 running configure again."
@@ -89,6 +97,8 @@ AC_LANG_POP([C++])
 
 # curl Library
 
+PKG_CHECK_MODULES([CURL], [libcurl >= 7.54.1])
+
 AC_CHECK_LIB([curl], [main], [], [echo "The cURL library must be installed on your system.
 Please check that this library is installed properly before
 running configure again."
@@ -192,5 +202,5 @@ AM_COND_IF([GTEST_FOUND], [AC_SUBST([GTEST], [`cat tests/test.commands`])],
        [AC_SUBST([GTEST], ["   @echo \"Google Test was not found on the system. Unable to build tests.\""])])
 AM_COND_IF([GTEST_FOUND], [echo "Google Test found on the system. Enabling Unit Tests."]);
 
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([Makefile tests/Makefile])
 AC_OUTPUT
Xestia Software Development
Yn Maystri
© 2006 - 2019 Xestia Software Development
Software

Xestia Address Book
Xestia Calendar
Development

Xestia Gelforn
Everything else

About
News
Privacy Policy