Home | News | Projects | Releases
Bugs | RFE | Repositories | Help
Move INSTALL, LICENSE, README, THANKS and TODO into root directory
[xestiaab/.git] / source / configure.ac
index c2582f6..5834f8b 100644 (file)
@@ -2,7 +2,7 @@
 # Process this file with autoconf to produce a configure script.
 
 AC_PREREQ([2.68])
-AC_INIT([Xestia Address Book], [0.01], [bugs@xestia.co.uk])
+AC_INIT([Xestia Address Book], [0.05], [bugs@xestia.co.uk])
 #AC_CONFIG_SRCDIR([version.h])
 #AC_CONFIG_HEADERS([config.h])
 
@@ -32,6 +32,12 @@ fi
 BINDIR=`eval echo $bindir`
 AC_SUBST([BINDIR])
 
+if test "x$datarootdir" = "xNONE" ; then
+       datarootdir="/share"
+fi
+DATAROOTDIR=`eval echo $datarootdir`
+AC_SUBST([DATAROOTDIR])
+
 # Checks for libraries.
 
 # wxWidgets
@@ -43,6 +49,9 @@ AC_LANG_PUSH([C++])
 CPPFLAGS="$CPPFLAGS -std=c++11"
 CXXFLAGS="$CXXFLAGS -std=c++11"
 
+# Checks for header files.
+AC_CHECK_HEADERS([stdlib.h string.h iostream iomanip ios algorithm map vector utility])
+
 AC_CHECK_HEADER([thread], [], [echo "The C++ compiler does not support C++11 extensions which is
 needed for Xestia Address Book. Please install or use a 
 compiler that supports C++11 extensions."
@@ -70,6 +79,8 @@ LIBS="$LIBS $WX_LIBS"
 
 # SFML Audio Library
 
+PKG_CHECK_MODULES([SFML], [sfml-all >= 2.4.1])
+
 AC_CHECK_LIB([sfml-audio], [main], [], [echo "The SFML libraries must be installed on your system.
 Please check that this library is installed properly before
 running configure again."
@@ -82,10 +93,12 @@ before running configure again."
        exit -1
        ])
 
-AC_LANG_PUSH([C++])
+AC_LANG_POP([C++])
 
 # curl Library
 
+PKG_CHECK_MODULES([CURL], [libcurl >= 7.54.1])
+
 AC_CHECK_LIB([curl], [main], [], [echo "The cURL library must be installed on your system.
 Please check that this library is installed properly before
 running configure again."
@@ -107,6 +120,38 @@ variable before running configure again."
        exit -1
        ])
 
+# file application
+
+AC_CHECK_PROG([FOUND_FILE], [file], [yes], [no]) 
+AM_CONDITIONAL([FOUND_FILE_RES], [test x$FOUND_FILE = xyes])
+
+AM_COND_IF([FOUND_FILE_RES], [], [echo "Cannot find the file program on your system.
+If it is installed on your system, adjust your PATH environment
+variable before running configure again."
+       exit -1
+       ])
+
+# uuidgen application
+
+AC_CHECK_PROG([FOUND_UUIDGEN], [uuidgen], [yes], [no]) 
+AM_CONDITIONAL([FOUND_UUIDGEN_RES], [test x$FOUND_UUIDGEN = xyes])
+
+AM_COND_IF([FOUND_UUIDGEN_RES], [], [echo "Cannot find the uuidgen program on your system.
+If it is installed on your system, adjust your PATH environment
+variable before running configure again."
+       exit -1
+       ])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_STDBOOL
+AC_C_INLINE
+
+# Check for Google Test and if it exists, enable the tests.
+
+AC_LANG_PUSH([C++])
+AC_CHECK_HEADERS([gtest/gtest.h], [gtestfound=yes], [gtestfound=no])
+AC_LANG_POP([C++])
+
 # libxml2 Library
 
 CPPFLAGSOLD=CPPFLAGS
@@ -135,35 +180,6 @@ before running configure again."
 
 CPPFLAGS=CPPFLAGSOLD
 
-# file application
-
-AC_CHECK_PROG([FOUND_FILE], [file], [yes], [no]) 
-AM_CONDITIONAL([FOUND_FILE_RES], [test x$FOUND_FILE = xyes])
-
-AM_COND_IF([FOUND_FILE_RES], [], [echo "Cannot find the file program on your system.
-If it is installed on your system, adjust your PATH environment
-variable before running configure again."
-       exit -1
-       ])
-
-# uuidgen application
-
-AC_CHECK_PROG([FOUND_UUIDGEN], [uuidgen], [yes], [no]) 
-AM_CONDITIONAL([FOUND_UUIDGEN_RES], [test x$FOUND_UUIDGEN = xyes])
-
-AM_COND_IF([FOUND_UUIDGEN_RES], [], [echo "Cannot find the uuidgen program on your system.
-If it is installed on your system, adjust your PATH environment
-variable before running configure again."
-       exit -1
-       ])
-
-# Checks for header files.
-AC_CHECK_HEADERS([stdlib.h string.h iostream iomanip ios algorithm map vector utility])
-
-# Checks for typedefs, structures, and compiler characteristics.
-AC_HEADER_STDBOOL
-AC_C_INLINE
-
 # Setup the debug setting.
 
 AC_ARG_ENABLE([debug],
@@ -181,5 +197,10 @@ AM_COND_IF([DEBUG], [AC_SUBST([DBGOUT], ["-O0 -ggdb"])], [AC_SUBST([DBGOUT], ["-
 AM_COND_IF([DEBUG], [AC_SUBST([DBGSTATUS], ["DEBUG=true"])], [AC_SUBST([DBGSTATUS], ["DEBUG=false"])])
 AM_COND_IF([DEBUG], [echo "Debugging mode has been enabled."])
 
-AC_CONFIG_FILES([Makefile])
+AM_CONDITIONAL([GTEST_FOUND], [test x$gtestfound = xyes])
+AM_COND_IF([GTEST_FOUND], [AC_SUBST([GTEST], [`cat tests/test.commands`])], 
+       [AC_SUBST([GTEST], ["   @echo \"Google Test was not found on the system. Unable to build tests.\""])])
+AM_COND_IF([GTEST_FOUND], [echo "Google Test found on the system. Enabling Unit Tests."]);
+
+AC_CONFIG_FILES([Makefile tests/Makefile])
 AC_OUTPUT
Xestia Software Development
Yn Maystri
© 2006 - 2019 Xestia Software Development
Software

Xestia Address Book
Xestia Calendar
Development

Xestia Gelforn
Everything else

About
News
Privacy Policy