Home | News | Projects | Releases
Bugs | RFE | Repositories | Help
Updated build system.
[xestiaab/.git] / source / configure.ac
index 6e792d3..16eb213 100644 (file)
@@ -13,6 +13,25 @@ AC_PROG_CXX
 AC_PROG_CC
 AC_PROG_CPP
 
+# Check prefix directories.
+
+if test "x$prefix" = "xNONE" ; then
+       prefix="/usr/local"
+fi
+
+if test "x$exec_prefix" = "xNONE" ; then
+       exec_prefix=$prefix
+fi
+
+PREFIX=$prefix
+AC_SUBST([PREFIX])
+
+if test "x$bindir" = "xNONE" ; then
+       bindir="/bin"
+fi
+BINDIR=`eval echo $bindir`
+AC_SUBST([BINDIR])
+
 # Checks for libraries.
 
 # wxWidgets
@@ -63,20 +82,6 @@ before running configure again."
        exit -1
        ])
 
-# ossp-uuid Library
-
-AC_CHECK_LIB([ossp-uuid++], [main], [], [echo "The OSSP UUID C++ library must be installed on your system.
-Please check that this library is installed properly before
-running configure again."
-       exit -1
-       ])
-
-AC_CHECK_HEADER([ossp/uuid++.hh], [], [echo "The OSSP UUID C++ library headers must be installed on your system.
-Please check that the library headers are installed properly
-before running configure again."
-       exit -1
-       ])
-
 AC_LANG_PUSH([C++])
 
 # curl Library
@@ -125,6 +130,17 @@ variable before running configure again."
        exit -1
        ])
 
+# uuidgen application
+
+AC_CHECK_PROG([FOUND_UUIDGEN], [uuidgen], [yes], [no]) 
+AM_CONDITIONAL([FOUND_UUIDGEN_RES], [test x$FOUND_UUIDGEN = xyes])
+
+AM_COND_IF([FOUND_UUIDGEN_RES], [], [echo "Cannot find the uuidgen program on your system.
+If it is installed on your system, adjust your PATH environment
+variable before running configure again."
+       exit -1
+       ])
+
 # Checks for header files.
 AC_CHECK_HEADERS([stdlib.h string.h iostream iomanip ios algorithm map vector utility])
 
@@ -135,7 +151,7 @@ AC_C_INLINE
 # Setup the debug setting.
 
 AC_ARG_ENABLE([debug],
-[  --enable-debug          Enable a debugging build],
+[  --enable-debug          Enable debugging features for the build.],
 [case "${enableval}" in
        yes) debug=true;;
        no)  debug=false;;
Xestia Software Development
Yn Maystri
© 2006 - 2019 Xestia Software Development
Software

Xestia Address Book
Xestia Calendar
Development

Xestia Gelforn
Everything else

About
News
Privacy Policy