Home | News | Projects | Releases
Bugs | RFE | Repositories | Help
Migrate building on Windows to using CMake
[xestiaab/.git] / source / common / CMakeLists.txt
index 552d13b..588c631 100644 (file)
@@ -1,6 +1,6 @@
 set(TARGET_NAME "common")
 
-set(FILE_LIST base64.cpp
+list(APPEND FILE_LIST base64.cpp
               base64.h
               CMakeLists.txt
               defaults.cpp
@@ -32,9 +32,9 @@ set(FILE_LIST base64.cpp
               uuid.cpp
               uuid.h)
 
-if(WIN32)
-    list(APPEND ${FILE_LIST} win32ssl.cpp
-                             win32ssl.h)
+if(MSVC)
+    list(APPEND FILE_LIST win32ssl.cpp
+                          win32ssl.h)
 endif()
 
 add_library(${TARGET_NAME}
Xestia Software Development
Yn Maystri
© 2006 - 2019 Xestia Software Development
Software

Xestia Address Book
Xestia Calendar
Development

Xestia Gelforn
Everything else

About
News
Privacy Policy